Author Message

<  Device Information  ~  Can't dial up using Huawei UMG1831

PostPosted: Mon Jul 09, 2012 8:58 pm Reply with quote
Posts: 22 Joined: Wed Apr 04, 2012 1:12 am Location: Vancouver, BC
Hi,

Am trying to dial up to Rogers Canada with the Huawei UMG1831. The modeswitch itself seems to have worked but I'm getting this with my chat script:
Code:
Setting the abort string

Initializing modem

Setting APN

Dialing...
Script /usr/sbin/chat -v -t6 -f /etc/ppp/peers/gsm_chat finished (pid 1164), status = 0x0
Serial connection established.
using channel 2
Using interface ppp0
Connect: ppp0 <--> /dev/ttyUSB2
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xefcd908b> <pcomp> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xefcd908b> <pcomp> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xefcd908b> <pcomp> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xefcd908b> <pcomp> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xefcd908b> <pcomp> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xefcd908b> <pcomp> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xefcd908b> <pcomp> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xefcd908b> <pcomp> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xefcd908b> <pcomp> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xefcd908b> <pcomp> <accomp>]
LCP: timeout sending Config-Requests
Connection terminated.
Receive serial link is not 8-bit clean:
Problem: all had bit 7 set to 0
Modem hangup

Does this haver anything to do with the modeswitch not being executed correctly?
lsusb is showing me this, which looks good to me...?:
Code:
# lsusb
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 005: ID 12d1:1404 Huawei Technologies Co., Ltd.


Thanks for any help or assistance you may be able to give.


Offline
PostPosted: Mon Jul 09, 2012 10:02 pm Reply with quote
Site Admin Posts: 6474 Joined: Sat Nov 03, 2007 12:30 am
May I see the contents of your chat file?


Offline
PostPosted: Mon Jul 09, 2012 10:08 pm Reply with quote
Posts: 22 Joined: Wed Apr 04, 2012 1:12 am Location: Vancouver, BC
Josh wrote:
May I see the contents of your chat file?

Certainly, please see below:
Code:
SAY 'Starting Rogers Wireless GSM connect script...\n'
SAY '\n'

#######################################
SAY 'Setting the abort string\n'
SAY '\n'
# Abort String ------------------------------
ABORT 'NO DIAL TONE' ABORT 'NO ANSWER' ABORT 'NO CARRIER' ABORT DELAYED

#######################################
SAY 'Initializing modem\n'
# Modem Initialization
'' AT
OK ATZ

#######################################
SAY '\n'
SAY     'Setting APN\n'
# Access Point Name (APN)
# Incorrect APN or CGDCONT can often cause errors in connection.
# Below are a bunch of different popular APNs

#REG:\s1 AT+cgdcont=1,"IP","proxy"
#OK     'AT+CGDCONT=0,"IP","proxy"'
#OK     'AT+CGDCONT=1,"IP","proxy"'
#OK     'AT+CGDCONT=2,"IP","proxy"'
OK     'AT+CGDCONT=1,"IP","vpn.com"'
#OK     'AT+CGDCONT=1,"IP","ISP.TELUS.COM"'
#OK     'AT+CGDCONT=1,"IP","INTERNET.COM"'
#OK     'AT+CGDCONT=1,"IP","ISP.CINGULAR"'
#OK     'AT+CGDCONT=2,"IP","ISP.CINGULAR"'

#######################################
SAY '\n'
SAY     'Dialing...\n'
# Dial the ISP, this is the common Cingular dial string

OK ATDT*99#
CONNECT ''

This APN works fine when I tested it on a Windows laptop.


Offline
PostPosted: Mon Jul 09, 2012 10:39 pm Reply with quote
Site Admin Posts: 6474 Joined: Sat Nov 03, 2007 12:30 am
I would still try other Rogers APNs (there seems to be a whole bunch of them).

Which dial string is Windows using? I have had reports of quirks with that too.

Once there was a way to log the entire modem init phase on Windows. I don't even know if that still works. In the worst case, you can use a USB sniffer to catch the dial string ...



Offline
PostPosted: Mon Jul 09, 2012 10:57 pm Reply with quote
Posts: 22 Joined: Wed Apr 04, 2012 1:12 am Location: Vancouver, BC
Where would I get the log from or also, is there a preferred USB sniffer I should use?

Thanks,
Ron


Offline
PostPosted: Mon Jul 09, 2012 11:12 pm Reply with quote
Site Admin Posts: 6474 Joined: Sat Nov 03, 2007 12:30 am
Just checked on Windows 7 - logging still works.

System Control -> Phone and Modems -> Modems. Here your modem should be listed; if it is connected, "Properties" will be available.

In the "Properties" dialog, there should be an admin button "Change settings". Afterwards, the "Logging" checkbox on the "Diagnosis" tab is selectable.

Note that I'm on a German language system. I don't know if my translations are correct to the point ...



Offline
PostPosted: Tue Jul 10, 2012 12:06 am Reply with quote
Posts: 22 Joined: Wed Apr 04, 2012 1:12 am Location: Vancouver, BC
Josh wrote:
Just checked on Windows 7 - logging still works.

System Control -> Phone and Modems -> Modems. Here your modem should be listed; if it is connected, "Properties" will be available.

In the "Properties" dialog, there should be an admin button "Change settings". Afterwards, the "Logging" checkbox on the "Diagnosis" tab is selectable.

Note that I'm on a German language system. I don't know if my translations are correct to the point ...



Great! Yep, that worked. :)
Translation was pretty good but System Conbtrol is called Control Panel otherwise it was pretty much bang on! :)
I dialed up with the logging enabled and got following (tried three times):
Code:
07-09-2012 14:33:19.286 - File: C:\Windows\system32\tapisrv.dll, Version 6.1.7601   
07-09-2012 14:33:19.286 - File: C:\Windows\system32\unimdm.tsp, Version 6.1.7601   
07-09-2012 14:33:19.286 - File: C:\Windows\system32\unimdmat.dll, Version 6.1.7601   
07-09-2012 14:33:19.287 - File: C:\Windows\system32\uniplat.dll, Version 6.1.7600   
07-09-2012 14:33:19.287 - File: C:\Windows\system32\drivers\modem.sys, Version 6.1.7600   
07-09-2012 14:33:19.287 - File: C:\Windows\system32\modemui.dll, Version 6.1.7600   
07-09-2012 14:33:19.289 - File: C:\Windows\system32\mdminst.dll, Version 6.1.7600   
07-09-2012 14:33:19.289 - Modem type: HUAWEI Mobile Connect - 3G Modem
07-09-2012 14:33:19.289 - Modem inf path: oem20.inf
07-09-2012 14:33:19.289 - Modem inf section: Modem0
07-09-2012 14:33:19.289 - Matching hardware ID: usb\vid_12d1&pid_1404&mi_00
07-09-2012 14:33:19.301 - Opening Modem
07-09-2012 14:33:19.301 - 460800,8,N,1, ctsfl=0, rtsctl=1
07-09-2012 14:33:19.305 - Initializing modem.
07-09-2012 14:33:19.306 - CD is high while initializing modem.
07-09-2012 14:33:19.316 - Send: AT<cr>
07-09-2012 14:33:19.324 - Recv: <cr><lf>OK<cr><lf>
07-09-2012 14:33:19.324 - Interpreted response: OK
07-09-2012 14:33:19.334 - Send: AT&FE0V1X1&D2&C1S0=0<cr>
07-09-2012 14:33:19.340 - Recv: <cr><lf>OK<cr><lf>
07-09-2012 14:33:19.341 - Interpreted response: OK
07-09-2012 14:33:19.351 - Send: AT<cr>
07-09-2012 14:33:19.356 - Recv: <cr><lf>OK<cr><lf>
07-09-2012 14:33:19.356 - Interpreted response: OK
07-09-2012 14:33:19.356 - Waiting for a call.
07-09-2012 14:33:19.366 - Send: ATS0=0<cr>
07-09-2012 14:33:19.367 - Recv: <cr><lf>OK<cr><lf>
07-09-2012 14:33:19.367 - Interpreted response: OK
07-09-2012 14:33:19.419 - TSP(0000): Making Call
07-09-2012 14:33:19.419 - 460800,8,N,1, ctsfl=0, rtsctl=1
07-09-2012 14:33:19.424 - Initializing modem.
07-09-2012 14:33:19.434 - Send: AT<cr>
07-09-2012 14:33:19.440 - Recv: <cr><lf>OK<cr><lf>
07-09-2012 14:33:19.440 - Interpreted response: OK
07-09-2012 14:33:19.450 - Send: AT&FE0V1X1&D2&C1S0=0<cr>
07-09-2012 14:33:19.457 - Recv: <cr><lf>OK<cr><lf>
07-09-2012 14:33:19.457 - Interpreted response: OK
07-09-2012 14:33:19.467 - Send: AT<cr>
07-09-2012 14:33:19.473 - Recv: <cr><lf>OK<cr><lf>
07-09-2012 14:33:19.473 - Interpreted response: OK
07-09-2012 14:33:19.473 - Dialing.
07-09-2012 14:33:19.473 - TSP Completing Async Operation(0x00010389) Status 0x00000000
07-09-2012 14:33:19.474 - TSP(0000): LINEEVENT: LINECALLSTATE_DIALING
07-09-2012 14:33:19.474 - TSP(0000): LINEEVENT: LINECALLSTATE_PROCEEDING
07-09-2012 14:33:19.483 - Send: ATDT###*<cr>
07-09-2012 14:33:21.216 - Recv: <cr><lf>NO CARRIER<cr><lf>
07-09-2012 14:33:21.216 - Interpreted response: No Carrier
07-09-2012 14:33:21.216 - Hanging up the modem.
07-09-2012 14:33:21.226 - Send: ATH E1<cr>
07-09-2012 14:33:21.230 - Recv: <cr><lf>OK<cr><lf>
07-09-2012 14:33:21.230 - Interpreted response: OK
07-09-2012 14:33:21.231 - 460800,8,N,1, ctsfl=0, rtsctl=1
07-09-2012 14:33:21.237 - Initializing modem.
07-09-2012 14:33:21.247 - Send: AT<cr>
07-09-2012 14:33:21.254 - Command Echo
07-09-2012 14:33:21.254 - Recv: <cr><lf>OK<cr><lf>
07-09-2012 14:33:21.254 - Interpreted response: OK
07-09-2012 14:33:21.264 - Send: AT&FE0V1X1&D2&C1S0=0<cr>
07-09-2012 14:33:21.270 - Command Echo
07-09-2012 14:33:21.270 - Recv: <cr><lf>OK<cr><lf>
07-09-2012 14:33:21.270 - Interpreted response: OK
07-09-2012 14:33:21.280 - Send: AT<cr>
07-09-2012 14:33:21.281 - Recv: <cr><lf>OK<cr><lf>
07-09-2012 14:33:21.281 - Interpreted response: OK
07-09-2012 14:33:21.281 - Waiting for a call.
07-09-2012 14:33:21.291 - Send: ATS0=0<cr>
07-09-2012 14:33:21.298 - Recv: <cr><lf>OK<cr><lf>
07-09-2012 14:33:21.298 - Interpreted response: OK
07-09-2012 14:33:21.298 - TSP(0000): LINEEVENT: LINECALLSTATE_DISCONNECTED(0x40)
07-09-2012 14:33:21.299 - TSP(0000): LINEEVENT: LINECALLSTATE_IDLE
07-09-2012 14:33:21.316 - TSP(0000): Dropping Call
07-09-2012 14:33:21.316 - TSP Completing Async Operation(0x00010378) Status 0x00000000
07-09-2012 14:33:21.322 - TSP(0000): Closing Call
07-09-2012 14:33:21.325 - Session Statistics:
07-09-2012 14:33:21.325 -                Reads : 48 bytes
07-09-2012 14:33:21.325 -                Writes: 34 bytes
07-09-2012 14:38:55.564 - File: C:\Windows\system32\tapisrv.dll, Version 6.1.7601   
07-09-2012 14:38:55.565 - File: C:\Windows\system32\unimdm.tsp, Version 6.1.7601   
07-09-2012 14:38:55.565 - File: C:\Windows\system32\unimdmat.dll, Version 6.1.7601   
07-09-2012 14:38:55.565 - File: C:\Windows\system32\uniplat.dll, Version 6.1.7600   
07-09-2012 14:38:55.565 - File: C:\Windows\system32\drivers\modem.sys, Version 6.1.7600   
07-09-2012 14:38:55.566 - File: C:\Windows\system32\modemui.dll, Version 6.1.7600   
07-09-2012 14:38:55.566 - File: C:\Windows\system32\mdminst.dll, Version 6.1.7600   
07-09-2012 14:38:55.566 - Modem type: HUAWEI Mobile Connect - 3G Modem
07-09-2012 14:38:55.566 - Modem inf path: oem20.inf
07-09-2012 14:38:55.566 - Modem inf section: Modem0
07-09-2012 14:38:55.566 - Matching hardware ID: usb\vid_12d1&pid_1404&mi_00
07-09-2012 14:38:55.579 - Opening Modem
07-09-2012 14:38:55.579 - 460800,8,N,1, ctsfl=0, rtsctl=1
07-09-2012 14:38:55.584 - Initializing modem.
07-09-2012 14:38:55.584 - CD is high while initializing modem.
07-09-2012 14:38:55.594 - Send: AT<cr>
07-09-2012 14:38:55.595 - Recv: <cr><lf>OK<cr><lf>
07-09-2012 14:38:55.595 - Interpreted response: OK
07-09-2012 14:38:55.605 - Send: AT&FE0V1X1&D2&C1S0=0<cr>
07-09-2012 14:38:55.611 - Recv: <cr><lf>OK<cr><lf>
07-09-2012 14:38:55.611 - Interpreted response: OK
07-09-2012 14:38:55.621 - Send: AT<cr>
07-09-2012 14:38:55.627 - Recv: <cr><lf>OK<cr><lf>
07-09-2012 14:38:55.627 - Interpreted response: OK
07-09-2012 14:38:55.627 - Waiting for a call.
07-09-2012 14:38:55.636 - TSP(0000): Making Call
07-09-2012 14:38:55.637 - Send: ATS0=0<cr>
07-09-2012 14:38:55.638 - Recv: <cr><lf>OK<cr><lf>
07-09-2012 14:38:55.638 - Interpreted response: OK
07-09-2012 14:38:55.638 - 460800,8,N,1, ctsfl=0, rtsctl=1
07-09-2012 14:38:55.642 - Initializing modem.
07-09-2012 14:38:55.653 - Send: AT<cr>
07-09-2012 14:38:55.654 - Recv: <cr><lf>OK<cr><lf>
07-09-2012 14:38:55.654 - Interpreted response: OK
07-09-2012 14:38:55.664 - Send: AT&FE0V1X1&D2&C1S0=0<cr>
07-09-2012 14:38:55.669 - Recv: <cr><lf>OK<cr><lf>
07-09-2012 14:38:55.669 - Interpreted response: OK
07-09-2012 14:38:55.680 - Send: AT<cr>
07-09-2012 14:38:55.686 - Recv: <cr><lf>OK<cr><lf>
07-09-2012 14:38:55.686 - Interpreted response: OK
07-09-2012 14:38:55.686 - Dialing.
07-09-2012 14:38:55.686 - TSP Completing Async Operation(0x00010234) Status 0x00000000
07-09-2012 14:38:55.686 - TSP(0000): LINEEVENT: LINECALLSTATE_DIALING
07-09-2012 14:38:55.687 - TSP(0000): LINEEVENT: LINECALLSTATE_PROCEEDING
07-09-2012 14:38:55.696 - Send: ATDT###*<cr>
07-09-2012 14:38:57.360 - Recv: <cr><lf>NO CARRIER<cr><lf>
07-09-2012 14:38:57.360 - Interpreted response: No Carrier
07-09-2012 14:38:57.360 - Hanging up the modem.
07-09-2012 14:38:57.370 - Send: ATH E1<cr>
07-09-2012 14:38:57.375 - Recv: <cr><lf>OK<cr><lf>
07-09-2012 14:38:57.376 - Interpreted response: OK
07-09-2012 14:38:57.376 - 460800,8,N,1, ctsfl=0, rtsctl=1
07-09-2012 14:38:57.382 - Initializing modem.
07-09-2012 14:38:57.392 - Send: AT<cr>
07-09-2012 14:38:57.400 - Command Echo
07-09-2012 14:38:57.400 - Recv: <cr><lf>OK<cr><lf>
07-09-2012 14:38:57.401 - Interpreted response: OK
07-09-2012 14:38:57.411 - Send: AT&FE0V1X1&D2&C1S0=0<cr>
07-09-2012 14:38:57.417 - Command Echo
07-09-2012 14:38:57.417 - Recv: <cr><lf>OK<cr><lf>
07-09-2012 14:38:57.417 - Interpreted response: OK
07-09-2012 14:38:57.427 - Send: AT<cr>
07-09-2012 14:38:57.428 - Recv: <cr><lf>OK<cr><lf>
07-09-2012 14:38:57.428 - Interpreted response: OK
07-09-2012 14:38:57.428 - Waiting for a call.
07-09-2012 14:38:57.438 - Send: ATS0=0<cr>
07-09-2012 14:38:57.444 - Recv: <cr><lf>OK<cr><lf>
07-09-2012 14:38:57.444 - Interpreted response: OK
07-09-2012 14:38:57.444 - TSP(0000): LINEEVENT: LINECALLSTATE_DISCONNECTED(0x40)
07-09-2012 14:38:57.445 - TSP(0000): LINEEVENT: LINECALLSTATE_IDLE
07-09-2012 14:38:57.464 - TSP(0000): Dropping Call
07-09-2012 14:38:57.464 - TSP Completing Async Operation(0x00010201) Status 0x00000000
07-09-2012 14:38:57.474 - TSP(0000): Closing Call
07-09-2012 14:38:57.478 - Session Statistics:
07-09-2012 14:38:57.478 -                Reads : 48 bytes
07-09-2012 14:38:57.478 -                Writes: 34 bytes
07-09-2012 14:38:59.489 - File: C:\Windows\system32\tapisrv.dll, Version 6.1.7601   
07-09-2012 14:38:59.489 - File: C:\Windows\system32\unimdm.tsp, Version 6.1.7601   
07-09-2012 14:38:59.489 - File: C:\Windows\system32\unimdmat.dll, Version 6.1.7601   
07-09-2012 14:38:59.489 - File: C:\Windows\system32\uniplat.dll, Version 6.1.7600   
07-09-2012 14:38:59.490 - File: C:\Windows\system32\drivers\modem.sys, Version 6.1.7600   
07-09-2012 14:38:59.490 - File: C:\Windows\system32\modemui.dll, Version 6.1.7600   
07-09-2012 14:38:59.491 - File: C:\Windows\system32\mdminst.dll, Version 6.1.7600   
07-09-2012 14:38:59.491 - Modem type: HUAWEI Mobile Connect - 3G Modem
07-09-2012 14:38:59.491 - Modem inf path: oem20.inf
07-09-2012 14:38:59.491 - Modem inf section: Modem0
07-09-2012 14:38:59.491 - Matching hardware ID: usb\vid_12d1&pid_1404&mi_00
07-09-2012 14:38:59.500 - Opening Modem
07-09-2012 14:38:59.500 - 460800,8,N,1, ctsfl=0, rtsctl=1
07-09-2012 14:38:59.504 - Initializing modem.
07-09-2012 14:38:59.514 - Send: AT<cr>
07-09-2012 14:38:59.520 - Recv: <cr><lf>OK<cr><lf>
07-09-2012 14:38:59.520 - Interpreted response: OK
07-09-2012 14:38:59.530 - Send: AT&FE0V1X1&D2&C1S0=0<cr>
07-09-2012 14:38:59.536 - Recv: <cr><lf>OK<cr><lf>
07-09-2012 14:38:59.536 - Interpreted response: OK
07-09-2012 14:38:59.546 - Send: AT<cr>
07-09-2012 14:38:59.547 - Recv: <cr><lf>OK<cr><lf>
07-09-2012 14:38:59.547 - Interpreted response: OK
07-09-2012 14:38:59.547 - Waiting for a call.
07-09-2012 14:38:59.557 - Send: ATS0=0<cr>
07-09-2012 14:38:59.562 - Recv: <cr><lf>OK<cr><lf>
07-09-2012 14:38:59.563 - Interpreted response: OK
07-09-2012 14:38:59.563 - TSP(0000): Making Call
07-09-2012 14:38:59.563 - 460800,8,N,1, ctsfl=0, rtsctl=1
07-09-2012 14:38:59.568 - Initializing modem.
07-09-2012 14:38:59.578 - Send: AT<cr>
07-09-2012 14:38:59.579 - Recv: <cr><lf>OK<cr><lf>
07-09-2012 14:38:59.579 - Interpreted response: OK
07-09-2012 14:38:59.589 - Send: AT&FE0V1X1&D2&C1S0=0<cr>
07-09-2012 14:38:59.596 - Recv: <cr><lf>OK<cr><lf>
07-09-2012 14:38:59.596 - Interpreted response: OK
07-09-2012 14:38:59.606 - Send: AT<cr>
07-09-2012 14:38:59.607 - Recv: <cr><lf>OK<cr><lf>
07-09-2012 14:38:59.607 - Interpreted response: OK
07-09-2012 14:38:59.607 - Dialing.
07-09-2012 14:38:59.607 - TSP Completing Async Operation(0x00010112) Status 0x00000000
07-09-2012 14:38:59.607 - TSP(0000): LINEEVENT: LINECALLSTATE_DIALING
07-09-2012 14:38:59.608 - TSP(0000): LINEEVENT: LINECALLSTATE_PROCEEDING
07-09-2012 14:38:59.617 - Send: ATDT###*<cr>
07-09-2012 14:39:01.422 - Recv: <cr><lf>NO CARRIER<cr><lf>
07-09-2012 14:39:01.422 - Interpreted response: No Carrier
07-09-2012 14:39:01.422 - Hanging up the modem.
07-09-2012 14:39:01.439 - Send: ATH E1<cr>
07-09-2012 14:39:01.439 - Recv: <cr><lf>OK<cr><lf>
07-09-2012 14:39:01.439 - Interpreted response: OK
07-09-2012 14:39:01.439 - 460800,8,N,1, ctsfl=0, rtsctl=1
07-09-2012 14:39:01.449 - Initializing modem.
07-09-2012 14:39:01.459 - Send: AT<cr>
07-09-2012 14:39:01.459 - Command Echo
07-09-2012 14:39:01.459 - Recv: <cr><lf>OK<cr><lf>
07-09-2012 14:39:01.459 - Interpreted response: OK
07-09-2012 14:39:01.469 - Send: AT&FE0V1X1&D2&C1S0=0<cr>
07-09-2012 14:39:01.469 - Command Echo
07-09-2012 14:39:01.469 - Recv: <cr><lf>OK<cr><lf>
07-09-2012 14:39:01.469 - Interpreted response: OK
07-09-2012 14:39:01.479 - Send: AT<cr>
07-09-2012 14:39:01.479 - Recv: <cr><lf>OK<cr><lf>
07-09-2012 14:39:01.479 - Interpreted response: OK
07-09-2012 14:39:01.479 - Waiting for a call.
07-09-2012 14:39:01.489 - Send: ATS0=0<cr>
07-09-2012 14:39:01.495 - Recv: <cr><lf>OK<cr><lf>
07-09-2012 14:39:01.495 - Interpreted response: OK
07-09-2012 14:39:01.495 - TSP(0000): LINEEVENT: LINECALLSTATE_DISCONNECTED(0x40)
07-09-2012 14:39:01.496 - TSP(0000): LINEEVENT: LINECALLSTATE_IDLE
07-09-2012 14:39:01.513 - TSP(0000): Dropping Call
07-09-2012 14:39:01.513 - TSP Completing Async Operation(0x000100ef) Status 0x00000000
07-09-2012 14:39:01.522 - TSP(0000): Closing Call
07-09-2012 14:39:01.525 - Session Statistics:
07-09-2012 14:39:01.525 -                Reads : 48 bytes
07-09-2012 14:39:01.525 -                Writes: 34 bytes


Offline
PostPosted: Tue Jul 10, 2012 12:10 am Reply with quote
Posts: 22 Joined: Wed Apr 04, 2012 1:12 am Location: Vancouver, BC
I can not really extract how I have to redo my chat script...
e.g. where do they set the APN?


Thanks for your help Josh!

Ron


Offline
PostPosted: Tue Jul 10, 2012 1:16 am Reply with quote
Posts: 22 Joined: Wed Apr 04, 2012 1:12 am Location: Vancouver, BC
Ah, okay, I now came up with this chat script:
Code:
'ABORT' 'BUSY'
'ABORT' 'ERROR'
'ABORT' 'NO ANSWER'
'ABORT' 'NO CARRIER'
'ABORT' 'NO DIALTONE'
'' 'ATZ'
'OK' 'AT'
'OK' 'AT&FE0V1X1&D2&C1S0=0'
'OK' 'AT'
'OK' 'ATS0=0'
'OK' 'AT'
'OK' 'AT&FE0V1X1&D2&C1S0=0'
'OK' 'AT'
'OK' 'ATDT###*'
'NO CARRIER' 'ATH E1'
'OK' 'AT&FE0V1X1&D2&C1S0=0'
'OK' 'AT'
'OK' 'ATS0=0'
'OK' 'CONNECT'
''

which doesn't seem that bad, even tho I haven't specified an APN...
I'm getting this in syslog
Code:
...
connect messages
...
Jul  9 23:04:18 E10_semiosOffice local2.info chat[3065]: OK
Jul  9 23:04:18 E10_semiosOffice local2.info chat[3065]:  -- got it
Jul  9 23:04:18 E10_semiosOffice local2.info chat[3065]: send (CONNECT^M)
Jul  9 23:04:18 E10_semiosOffice daemon.debug pppd[3061]: Script /usr/sbin/chat -v -t6 -f /etc/ppp/peers/rogers_chat finished (pid 3064), status = 0x0
Jul  9 23:04:18 E10_semiosOffice daemon.info pppd[3061]: Serial connection established.
Jul  9 23:04:18 E10_semiosOffice daemon.debug pppd[3061]: using channel 4
Jul  9 23:04:18 E10_semiosOffice daemon.info pppd[3061]: Using interface ppp0
Jul  9 23:04:18 E10_semiosOffice daemon.notice pppd[3061]: Connect: ppp0 <--> /dev/ttyUSB2
Jul  9 23:04:19 E10_semiosOffice daemon.debug pppd[3061]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xf3bf7ea6> <pcomp> <accomp>]
Jul  9 23:04:22 E10_semiosOffice daemon.debug pppd[3061]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xf3bf7ea6> <pcomp> <accomp>]
Jul  9 23:04:25 E10_semiosOffice daemon.debug pppd[3061]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xf3bf7ea6> <pcomp> <accomp>]
Jul  9 23:04:28 E10_semiosOffice daemon.debug pppd[3061]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xf3bf7ea6> <pcomp> <accomp>]
Jul  9 23:04:31 E10_semiosOffice daemon.debug pppd[3061]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xf3bf7ea6> <pcomp> <accomp>]
Jul  9 23:04:34 E10_semiosOffice daemon.debug pppd[3061]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xf3bf7ea6> <pcomp> <accomp>]
Jul  9 23:04:37 E10_semiosOffice daemon.debug pppd[3061]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xf3bf7ea6> <pcomp> <accomp>]
Jul  9 23:04:40 E10_semiosOffice daemon.debug pppd[3061]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xf3bf7ea6> <pcomp> <accomp>]
Jul  9 23:04:43 E10_semiosOffice daemon.debug pppd[3061]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xf3bf7ea6> <pcomp> <accomp>]
Jul  9 23:04:46 E10_semiosOffice daemon.debug pppd[3061]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xf3bf7ea6> <pcomp> <accomp>]
Jul  9 23:04:49 E10_semiosOffice daemon.warn pppd[3061]: LCP: timeout sending Config-Requests
Jul  9 23:04:49 E10_semiosOffice daemon.notice pppd[3061]: Connection terminated.
Jul  9 23:04:49 E10_semiosOffice daemon.warn pppd[3061]: Receive serial link is not 8-bit clean:
Jul  9 23:04:49 E10_semiosOffice daemon.warn pppd[3061]: Problem: all had bit 7 set to 0
Jul  9 23:04:50 E10_semiosOffice daemon.notice pppd[3061]: Modem hangup
Jul  9 23:04:50 E10_semiosOffice daemon.info pppd[3061]: Exit.

So it still doesn't connect me but up there it says Serial connection established


Offline
PostPosted: Tue Jul 10, 2012 9:16 am Reply with quote
Site Admin Posts: 6474 Joined: Sat Nov 03, 2007 12:30 am
Huh? Windows did not connect at all ...

How exactly did you achieve your successful connection that you reported earlier?


Offline
PostPosted: Tue Jul 10, 2012 6:46 pm Reply with quote
Posts: 22 Joined: Wed Apr 04, 2012 1:12 am Location: Vancouver, BC
using usb_modeswitch with following config file:
Code:
########################################################
# Huawei, newer modems

DefaultVendor= 0x12d1
DefaultProduct=0x1446

TargetVendor=  0x12d1
TargetProductList="1001,1406,140b,140c,1412,141b,1433,14ac,1506,1404"

CheckSuccess=20

MessageContent="55534243123456780000000000000011062000000100000000000000000000"
#


Or are you possibly working of a succesful dial-up connection? Haven't gotten that working yet (only with Windows)


Offline
PostPosted: Tue Jul 10, 2012 7:28 pm Reply with quote
Site Admin Posts: 6474 Joined: Sat Nov 03, 2007 12:30 am
I don't quite understand.

You say the connection worked on a Windows laptop.

But the log from Windows that you posted shows that the connection failed:

07-09-2012 14:39:01.422 - Interpreted response: No Carrier
07-09-2012 14:39:01.422 - Hanging up the modem.

I suppose you tried to connect by starting the modem connection directly.

What you want is a log from a working connection. How did you establish the successful connection on the Windows laptop? Did you use special provider software?



Offline
PostPosted: Tue Jul 10, 2012 7:48 pm Reply with quote
Posts: 22 Joined: Wed Apr 04, 2012 1:12 am Location: Vancouver, BC
Josh wrote:
I don't quite understand.

You say the connection worked on a Windows laptop.

But the log from Windows that you posted shows that the connection failed:

07-09-2012 14:39:01.422 - Interpreted response: No Carrier
07-09-2012 14:39:01.422 - Hanging up the modem.

I suppose you tried to connect by starting the modem connection directly.

What you want is a log from a working connection. How did you establish the successful connection on the Windows laptop? Did you use special provider software?



Hoops, sorry.
Was looking the longest time at the wrong log. Just got a new one now:
Code:
07-10-2012 10:30:19.620 - File: C:\Windows\system32\tapisrv.dll, Version 6.1.7601   
07-10-2012 10:30:19.621 - File: C:\Windows\system32\unimdm.tsp, Version 6.1.7601   
07-10-2012 10:30:19.621 - File: C:\Windows\system32\unimdmat.dll, Version 6.1.7601   
07-10-2012 10:30:19.621 - File: C:\Windows\system32\uniplat.dll, Version 6.1.7600   
07-10-2012 10:30:19.621 - File: C:\Windows\system32\drivers\modem.sys, Version 6.1.7600   
07-10-2012 10:30:19.621 - File: C:\Windows\system32\modemui.dll, Version 6.1.7600   
07-10-2012 10:30:19.622 - File: C:\Windows\system32\mdminst.dll, Version 6.1.7600   
07-10-2012 10:30:19.622 - Modem type: HUAWEI Mobile Connect - 3G Modem
07-10-2012 10:30:19.622 - Modem inf path: oem20.inf
07-10-2012 10:30:19.622 - Modem inf section: Modem0
07-10-2012 10:30:19.622 - Matching hardware ID: usb\vid_12d1&pid_1404&mi_00
07-10-2012 10:30:19.629 - Opening Modem
07-10-2012 10:30:19.629 - 460800,8,N,1, ctsfl=0, rtsctl=1
07-10-2012 10:30:19.634 - Initializing modem.
07-10-2012 10:30:19.644 - Send: AT<cr>
07-10-2012 10:30:19.650 - Recv: <cr><lf>OK<cr><lf>
07-10-2012 10:30:19.650 - Interpreted response: OK
07-10-2012 10:30:19.660 - Send: AT&FE0V1X1&D2&C1S0=0<cr>
07-10-2012 10:30:19.661 - Recv: <cr><lf>OK<cr><lf>
07-10-2012 10:30:19.661 - Interpreted response: OK
07-10-2012 10:30:19.671 - Send: AT<cr>
07-10-2012 10:30:19.677 - Recv: <cr><lf>OK<cr><lf>
07-10-2012 10:30:19.677 - Interpreted response: OK
07-10-2012 10:30:19.677 - Waiting for a call.
07-10-2012 10:30:19.682 - TSP(0000): Making Call
07-10-2012 10:30:19.687 - Send: ATS0=0<cr>
07-10-2012 10:30:19.693 - Recv: <cr><lf>OK<cr><lf>
07-10-2012 10:30:19.693 - Interpreted response: OK
07-10-2012 10:30:19.693 - 460800,8,N,1, ctsfl=0, rtsctl=1
07-10-2012 10:30:19.697 - Initializing modem.
07-10-2012 10:30:19.707 - Send: AT<cr>
07-10-2012 10:30:19.709 - Recv: <cr><lf>OK<cr><lf>
07-10-2012 10:30:19.709 - Interpreted response: OK
07-10-2012 10:30:19.719 - Send: AT&FE0V1X1&D2&C1S0=0<cr>
07-10-2012 10:30:19.720 - Recv: <cr><lf>OK<cr><lf>
07-10-2012 10:30:19.720 - Interpreted response: OK
07-10-2012 10:30:19.730 - Send: AT<cr>
07-10-2012 10:30:19.736 - Recv: <cr><lf>OK<cr><lf>
07-10-2012 10:30:19.736 - Interpreted response: OK
07-10-2012 10:30:19.736 - Dialing.
07-10-2012 10:30:19.736 - TSP Completing Async Operation(0x000102e1) Status 0x00000000
07-10-2012 10:30:19.737 - TSP(0000): LINEEVENT: LINECALLSTATE_DIALING
07-10-2012 10:30:19.738 - TSP(0000): LINEEVENT: LINECALLSTATE_PROCEEDING
07-10-2012 10:30:19.746 - Send: ATDT*###<cr>
07-10-2012 10:30:19.755 - Recv: <cr><lf>CONNECT 21600000<cr><lf>
07-10-2012 10:30:19.755 - Interpreted response: Connect
07-10-2012 10:30:19.755 - Receive Connect but CD was low, Waiting for signal to go high
07-10-2012 10:30:19.775 - CD has been raised
07-10-2012 10:30:19.775 - Connection established at 21600000bps.
07-10-2012 10:30:19.775 - Error-control off or unknown.
07-10-2012 10:30:19.775 - Data compression off or unknown.
07-10-2012 10:30:19.776 - TSP(0000): LINEEVENT: LINECALLSTATE_CONNECTED
07-10-2012 10:30:49.776 - Read: Total: 1841177, Per/Sec: 63487, Written: Total: 162425, Per/Sec: 5599

That one looks better: LINECALLSTATE_CONNECTED


Offline
PostPosted: Tue Jul 10, 2012 8:26 pm Reply with quote
Posts: 22 Joined: Wed Apr 04, 2012 1:12 am Location: Vancouver, BC
redid my chat script to this:
Code:

'ABORT' 'BUSY'
'ABORT' 'ERROR'
'ABORT' 'NO ANSWER'
'ABORT' 'NO CARRIER'
'ABORT' 'NO DIALTONE'

'' 'AT'
'OK' 'AT&FE0V1X1&D2&C1S0=0'
'OK' 'AT'
'OK' 'ATS0=0'
'OK' 'AT'
'OK' 'AT&FE0V1X1&D2&C1S0=0'
'OK' 'AT'
#'OK' 'AT+CGDCONT=1,"IP","vpn.com"'
#'OK' 'AT'
'OK' 'ATDT*###'
#'NO CARRIER' 'ATH E1'
#'OK' 'AT&FE0V1X1&D2&C1S0=0'
#'OK' 'AT'
#'OK' 'ATS0=0'
'' 'CONNECT'

But my syslog says
Code:
...blabla chat...
Jul 10 18:42:39 E10_semiosOffice local2.info chat[15100]: send (ATDT*###^M)
Jul 10 18:42:39 E10_semiosOffice local2.info chat[15100]: send (CONNECT^M)
Jul 10 18:42:39 E10_semiosOffice daemon.debug pppd[15096]: Script /usr/sbin/chat -v -t6 -f /etc/ppp/peers/rogers_chat finished (pid 15099), status = 0x0
Jul 10 18:42:39 E10_semiosOffice daemon.info pppd[15096]: Serial connection established.
Jul 10 18:42:39 E10_semiosOffice daemon.debug pppd[15096]: using channel 10
Jul 10 18:42:39 E10_semiosOffice daemon.info pppd[15096]: Using interface ppp0
Jul 10 18:42:39 E10_semiosOffice daemon.notice pppd[15096]: Connect: ppp0 <--> /dev/ttyUSB2
Jul 10 18:42:40 E10_semiosOffice daemon.debug pppd[15096]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x91bb799> <pcomp> <accomp>]
Jul 10 18:42:43 E10_semiosOffice daemon.debug pppd[15096]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x91bb799> <pcomp> <accomp>]
Jul 10 18:42:46 E10_semiosOffice daemon.debug pppd[15096]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x91bb799> <pcomp> <accomp>]
Jul 10 18:42:49 E10_semiosOffice daemon.debug pppd[15096]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x91bb799> <pcomp> <accomp>]
Jul 10 18:42:52 E10_semiosOffice daemon.debug pppd[15096]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x91bb799> <pcomp> <accomp>]
Jul 10 18:42:55 E10_semiosOffice daemon.debug pppd[15096]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x91bb799> <pcomp> <accomp>]
Jul 10 18:42:58 E10_semiosOffice daemon.debug pppd[15096]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x91bb799> <pcomp> <accomp>]
Jul 10 18:43:01 E10_semiosOffice cron.info crond[600]: crond: USER root pid 15101 cmd /root/watchdog.sh
Jul 10 18:43:01 E10_semiosOffice daemon.debug pppd[15096]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x91bb799> <pcomp> <accomp>]
Jul 10 18:43:04 E10_semiosOffice daemon.debug pppd[15096]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x91bb799> <pcomp> <accomp>]
Jul 10 18:43:07 E10_semiosOffice daemon.debug pppd[15096]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x91bb799> <pcomp> <accomp>]
Jul 10 18:43:10 E10_semiosOffice daemon.warn pppd[15096]: LCP: timeout sending Config-Requests
Jul 10 18:43:10 E10_semiosOffice daemon.notice pppd[15096]: Connection terminated.
Jul 10 18:43:10 E10_semiosOffice daemon.warn pppd[15096]: Receive serial link is not 8-bit clean:
Jul 10 18:43:10 E10_semiosOffice daemon.warn pppd[15096]: Problem: all had bit 7 set to 0
Jul 10 18:43:11 E10_semiosOffice daemon.notice pppd[15096]: Modem hangup
Jul 10 18:43:11 E10_semiosOffice daemon.info pppd[15096]: Exit.

What's all that async stuff, I'm wondering...? :o


Offline
PostPosted: Tue Jul 10, 2012 10:28 pm Reply with quote
Site Admin Posts: 6474 Joined: Sat Nov 03, 2007 12:30 am
It is still not clear if you really have network on your Windows computer. The dialling is not your problem.

Again: how did you achieve the successful connection on the Windows laptop that you mentioned in one of your previous posts? Did you use special software? Did you check if you could access the Web?

Be so kind and answer these questions.



Offline

Display posts from previous:  Sort by:

All times are UTC+02:00
Page 1 of 2
25 posts
Go to page 1 2 Next
Users browsing this forum: No registered users and 1 guest
Search for:
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum