Activation Codes and Methods, Hardware Details, Sniffing
Post Reply
LazZy
Posts: 1
Joined: 02 Mar 2021, 07:24

Vodafone K5161h (12d1:1591)

Post by LazZy » 02 Mar 2021, 07:43

Hello everybody!
I can't find subj in the list of devices. I'm a noob and I don't understand what I need to do.
Please help!

Josh
Site Admin
Posts: 6570
Joined: 03 Nov 2007, 00:30

Re: Vodafone K5161h (12d1:1591)

Post by Josh » 17 Apr 2021, 14:23

The easiest way is to copy an existing config file like "12d1:1583", put it in "/etc/usb_modeswitch.d" and change the name to "12d1:1591".

That should make the modem switch the next time you insert it. To check if it worked, either run the "dmesg" command line tool repeatedly or enable usb_modeswitch's logging in "/etc/usb_modeswitch.conf" (with a text editor).

Once you know the "target" USB ID you can adapt it in the "12d1:1591" file, by using a simple text editor.

kgswift
Posts: 1
Joined: 30 Jun 2021, 22:57

Re: Vodafone K5161h (12d1:1591)

Post by kgswift » 30 Jun 2021, 23:03

This may not be the best place to ask but does anyone know if it's possible to disable the CD mode in the modem permanently? I'd like to use this in my router (Billion) but the dongle seems to remain in CD mode when connected. I did see some old comments for serial modems about AT commands to change this behaviour but this doesn't seem possible with the K5161.

LOM
Posts: 1380
Joined: 11 Jul 2012, 15:14
Location: Koh Samui, TH

Re: Vodafone K5161h (12d1:1591)

Post by LOM » 01 Jul 2021, 02:36

kgswift wrote: 30 Jun 2021, 23:03 This may not be the best place to ask but does anyone know if it's possible to disable the CD mode in the modem permanently? I'd like to use this in my router (Billion) but the dongle seems to remain in CD mode when connected. I did see some old comments for serial modems about AT commands to change this behaviour but this doesn't seem possible with the K5161.
If this is a K5161h with the USB Id 12d1:1591 then I suspect that it is already switched.
What does the cmd lsusb tell?

Post Reply