Page 1 of 1

Huawei E3531i-2 not switching Any working USB on the market?

Posted: 18 May 2019, 16:54
by Stefan73
Hello,

on Debian stretch (Raspbian lite) I try to get a Huawei E3531i-2 to work.

Code: Select all

>lsusb
Bus 001 Device 015: ID 12d1:14dc Huawei Technologies Co., Ltd. 
It switches from green to blue, but usb_modeswitch seems not to detect it and there is no /dev/modem linked.

Does anybody use this device?

I need devices like this for beehive scales and I don't love to buy used Huawei E160 just to find out, that they are not unlocked...
is there a useable USB-Dongle on the market I can buy as new?

Thank you very much!
Stefan

Re: Huawei E3531i-2 not switching Any working USB on the market?

Posted: 19 May 2019, 12:30
by LOM
12d1:14dc is USB Id after your E3531i-2 has switched mode, there is no more switching after that.
E3531i-2 /12d1:14dc is not a dial-up modem it has a direct ethernet interface and behaves like an ethernet adapter.

Re: Huawei E3531i-2 not switching Any working USB on the market?

Posted: 19 May 2019, 14:05
by Stefan73
Thank you!
Do you know, if there is any (offered as new) device available witch is usable with usb_modeswitch/wvdial/gammu-sms?

Stefan

Re: Huawei E3531i-2 not switching Any working USB on the market?

Posted: 19 May 2019, 15:22
by LOM
If you are using a fairly new version of usb_modeswitch (2.5.1 or 2.5.2) then you could try activating the switch HuaweiAltModeGlobal in /etc/usb_modeswitch.conf.
It may give you the dumb serial interfaces for dial-up modem instead of the smarter net-interface.

Re: Huawei E3531i-2 not switching Any working USB on the market?

Posted: 19 May 2019, 23:49
by Stefan73
Great!!! I already printed the retoure-label - and dont need it anymore!

Thank you very much!