Automatic Activation, Hotplug and UDEV, Configuration
Post Reply
Posts: 1
Joined: 20 Sep 2019, 20:32

Trying to setup HSDPA on Raspberry Pi

Post by sysponi0 » 20 Sep 2019, 20:59

Hi there,

I'm attempting to use a Vodafone V-Sim with a HSDPA Moden I picked up online. I've been told to use USB_ModeSwitch and I've gone through a multitude of options, all not working.

The LSUSB gives me the ID 05c6:1000 and looking online it and using the correct command to switch it, it seems to be a matter of changing the 1000 to a 6000. However, every time I do this it resets on reboot. I've tried setting it on the usb_modeswitch.conf, i've tried creating a .conf in usb_modeswitch.d under the name 05c6:1000 and neither have worked.

If you need any extra information please let me know. This device isn't any of the currently listed one's as far as I'm aware. It's a Qualcomm Modem 6000 whatever that means. Haha.


Site Admin
Posts: 6570
Joined: 03 Nov 2007, 00:30

Re: Trying to setup HSDPA on Raspberry Pi

Post by Josh » 10 Nov 2019, 15:26

Please disable switching in /etc/usb_modeswitch.conf and re-plug the modem.

Then run in a terminal:

Code: Select all

lsusb -v -d 05c6:1000
Copy and paste the complete output here (easier if you redirect it to a file first).
Make sure the formatting is kept by enclosing the whole output in a

Code: Select all


Post Reply