Page 1 of 1

Auto-Start Connection - failing

Posted: 14 Sep 2018, 03:08
by henrysinn
Huawei E3372h-607
Flashed with 21.200.07.00.00
Works perfectly except when using Auto-Start Connection

Looking for thoughts / changes ?

Connection gets stuck as attached "Error-NoModemResponse"
Lights are usually Blue when error occurs
May go Green over time with error still there
Manual connection works ONLY after lights are steady Green
Manual connection fails with same error if lights are Blue (or any time before lights go Green)
Need to wait for Green light before attempting connection.

Situation the same when used on Phone (oneplus.com) or Joying (carjoying.com) car head-unit


Working COM for phone:

11 Sep. 2018 2:55:03 pm
Device manufacturer string: OnePlus
Total RAM: 3017 MB. Available RAM: 1323 MB
New device on /dev/bus/usb/001/002
Class of interface 0 is 0x08
Looking at USB device 12d1:14fe with class 8
Device top dir: /sys/bus/usb/devices/1-1, active cfg: 1
Active configuration ID: 1
Device layout (config 1) - cl:00 sc:00 pr:00
if:0 as:0 - cl:08 sc:06 pr:50 - bi:81 bo:01
Found 0 serial ports
No dedicated modem port found
Trying to switch mode of USB device 12d1:14fe ...
Device info:
VID= 12d1
PID= 14fe
Manufact.= HUAWEI_MOBILE
Product= HUAWEI_MOBILE
Found matching configuration in collection: 12d1.14fe
Go for alternate Huawei mode as configured ...
Wait for 200 ms
Bulk message 1: 55534243123456780000000000000011063000000100010000000000000000
transmitted
New device on /dev/bus/usb/001/003
Class of interface 0 is 0xFF
Looking at USB device 12d1:155e with class 255
Device top dir: /sys/bus/usb/devices/1-1, active cfg: 1
Active configuration ID: 1
Device layout (config 1) - cl:02 sc:00 pr:00
if:0 as:0 - cl:ff sc:ff pr:ff - ir:83 bi:82 bo:02
if:1 as:0 - cl:ff sc:ff pr:ff - bi:84 bo:03
if:2 as:0 - cl:ff sc:ff pr:ff - bi:85 bo:04
if:3 as:0 - cl:02 sc:0d pr:00 - ir:87
if:4 as:0 - cl:0a sc:00 pr:01 -
if:4 as:1 - cl:0a sc:00 pr:01 - bi:86 bo:05
Found 3 serial ports (0, 1, 2)
Opening port type HUAWEI_NCM (interface 3)


Working COM for Joying:

Sep 11, 2018 4:37:13 PM
Device manufacturer string: Rockchip
Total RAM: 2017 MB. Available RAM: 1329 MB
New device on /dev/bus/usb/001/013
Class of interface 0 is 0x08
Looking at USB device 12d1:14fe with class 8
Device top dir: /sys/bus/usb/devices/1-1.2, active cfg: 1
Active configuration ID: 1
Device layout (config 1) - cl:00 sc:00 pr:00
if:0 as:0 - cl:08 sc:06 pr:50 - bi:81 bo:01
Found 0 serial ports
No dedicated modem port found
Trying to switch mode of USB device 12d1:14fe ...
Device info:
VID= 12d1
PID= 14fe
Manufact.= HUAWEI_MOBILE
Product= HUAWEI_MOBILE
Found matching configuration in collection: 12d1.14fe
Go for alternate Huawei mode as configured ...
Wait for 200 ms
Bulk message 1: 55534243123456780000000000000011063000000100010000000000000000
transmitted
New device on /dev/bus/usb/001/014
Class of interface 0 is 0xFF
Looking at USB device 12d1:155e with class 255
Device top dir: /sys/bus/usb/devices/1-1.2, active cfg: 1
Active configuration ID: 1
Device layout (config 1) - cl:02 sc:00 pr:00
if:0 as:0 - cl:ff sc:ff pr:ff - ir:83 bi:82 bo:02
if:1 as:0 - cl:ff sc:ff pr:ff - bi:84 bo:03
if:2 as:0 - cl:ff sc:ff pr:ff - bi:85 bo:04
if:3 as:0 - cl:02 sc:0d pr:00 - ir:87
if:4 as:0 - cl:0a sc:00 pr:01 -
if:4 as:1 - cl:0a sc:00 pr:01 - bi:86 bo:05
Found 3 serial ports (0, 1, 2)
Disable kernel USB power-save, as set in app config
Opening port type HUAWEI_NCM (interface 3)




Working PPP on Phone

Total RAM: 3017 MB. Available RAM: 1320 MB
Starting modem command sequence (Init) ...
>
ATE0
<
OK
>
AT+CGSN
<
866850027011437
OK
--> Using device profile 866850027011437
>
AT+CPIN?
<
+CPIN: READY
OK
>
AT+CIMI
<
505016000468799
OK
--> Using parameter profile 505016000468799
SIM is ready to use
====
11 Sep. 2018 2:55:30 pm
Total RAM: 3017 MB. Available RAM: 1351 MB
Starting modem command sequence (Dial) ...
>
AT+CPIN?
<
+CPIN: READY
OK
>
AT+CFUN?
<
+CFUN: 1
OK
>
AT^NDISDUP=1,1,"telstra.internet"
<
OK
>
AT_WAIT_IRQ
<
^RSSI: 3
^HCSQ:"WCDMA",22,14,49
^MODE: 5,9
^NDISSTAT:1,,,"IPV4"
IRQ OK
====
Dialling complete
====
Dialling complete
Starting DHCP request ...
> Phase 3
ffffffffffff001e101f0000080045100148000000008011399600000000ffffffff004400430134
<
ffffffffffff4c549945e5d50800450001160000000080114c540a62e321ffffffff004300440102
NAK received
> Phase 1
ffffffffffff001e101f0000080045100148000000008011399600000000ffffffff004400430134
<
ffffffffffff4c549945e5d508004500013e0001000080114c2b0a62e321ffffffff00430044012a
OFFER received
> Phase 3
4c549945e5d5001e101f0000080045100148000000008011399600000000ffffffff004400430134
<
ffffffffffff4c549945e5d508004500013e0002000080114c2a0a62e321ffffffff00430044012a
ACK received
> Phase 9
ffffffffffff001e101f000008060001080006040001001e101f00000a62e3270000000000000a62
< (ARP, connection confirmed)
001e101f00004c549945e5d5080600010800060400024c549945e5d50a62e321001e101f00000a62
Local IP: 10.98.227.39/28
Peer IP: 10.98.227.33
DNS1: 10.4.130.164
DNS2: 10.5.136.242
Send initial IP packet ...
First IP packet received - we are online
End of DHCP negotiation
VPN setup complete
VPN network device is up
Network notification accepted after 1200 ms
Connection is ready



Working PPP on Joying

Sep 11, 2018 4:37:16 PM
Total RAM: 2017 MB. Available RAM: 1327 MB
Starting modem command sequence (Init) ...
>
ATE0
<
OK
>
AT+CGSN
<
866850027011437
OK
--> Using device profile 866850027011437
>
AT+CPIN?
<
+CPIN: READY
OK
>
AT+CIMI
<
505016000468799
OK
--> Using parameter profile 505016000468799
SIM is ready to use
====
Sep 11, 2018 4:37:59 PM
Total RAM: 2017 MB. Available RAM: 1325 MB
Starting modem command sequence (Dial) ...
>
AT+CPIN?
<
+CPIN: READY
OK
>
AT+CFUN?
<
+CFUN: 1
OK
>
AT^NDISDUP=1,1,"telstra.internet"
<
OK
>
AT_WAIT_IRQ
<
^MODE: 5,9
^NDISSTAT:1,,,"IPV4"
IRQ OK
====
Dialling complete
====
Dialling complete
Starting DHCP request ...
> Phase 3
ffffffffffff001e101f0000080045100148000000008011399600000000ffffffff004400430134
<
ffffffffffff4c549945e5d508004500011600000000801103040a632c71ffffffff004300440102
NAK received
> Phase 1
ffffffffffff001e101f0000080045100148000000008011399600000000ffffffff004400430134
<
ffffffffffff4c549945e5d508004500013e00010000801102db0a632c71ffffffff00430044012a
OFFER received
> Phase 3
4c549945e5d5001e101f0000080045100148000000008011399600000000ffffffff004400430134
<
ffffffffffff4c549945e5d508004500013e00020000801102da0a632c71ffffffff00430044012a
ACK received
> Phase 9
ffffffffffff001e101f000008060001080006040001001e101f00000a632c770000000000000a63
< (ARP, connection confirmed)
001e101f00004c549945e5d5080600010800060400024c549945e5d50a632c71001e101f00000a63
Local IP: 10.99.44.119/28
Peer IP: 10.99.44.113
DNS1: 10.4.130.164
DNS2: 10.5.136.242
Send initial IP packet ...
First IP packet received - we are online
End of DHCP negotiation
VPN setup complete
VPN network device is up
Sep 11, 2018 4:45:31 PM
Total RAM: 2017 MB. Available RAM: 1075 MB
Network notification accepted after 0 ms
Connection is ready





Failing PPP on Phone


11 Sep. 2018 3:30:02 pm

Total RAM: 3017 MB. Available RAM: 1332 MB

Starting modem command sequence (Init) ...
>
ATE0
<
OK
>
AT+CGSN
<
866850027011437

OK
--> Using device profile 866850027011437
>
AT+CPIN?
<
+CPIN: READY

OK
>
AT+CIMI
<
505016000468799

OK
--> Using parameter profile 505016000468799

SIM is ready to use
====

11 Sep. 2018 3:30:16 pm

Total RAM: 3017 MB. Available RAM: 1340 MB

Starting modem command sequence (Dial) ...
>
AT+CPIN?
<
+CPIN: READY

OK
>
AT+CFUN?
<
+CFUN: 1

OK
>
AT^NDISDUP=1,1,"telstra.internet"
<
OK
>
AT_WAIT_IRQ
Timeout while waiting for modem reply
====




Failing PPP on Joying


Sep 11, 2018 5:00:16 PM
Total RAM: 2017 MB. Available RAM: 1136 MB
Starting modem command sequence (Init) ...
>
ATE0
<
OK
>
AT+CGSN
<
866850027011437
OK
--> Using device profile 866850027011437
>
AT+CPIN?
<
+CPIN: READY
OK
>
AT+CIMI
<
505016000468799
OK
--> Using parameter profile 505016000468799
SIM is ready to use
====
Sep 11, 2018 5:00:16 PM
Total RAM: 2017 MB. Available RAM: 1135 MB
Starting modem command sequence (Dial) ...
>
AT+CPIN?
<
+CPIN: READY
OK
>
AT+CFUN?
<
+CFUN: 1
OK
>
AT^NDISDUP=1,1,"telstra.internet"
<
OK
>
AT_WAIT_IRQ
Timeout while waiting for modem reply
====

Re: Auto-Start Connection - failing

Posted: 25 Sep 2018, 20:45
by Josh
Hi again - sorry for the late reply, but I've been on vacation for a while ...

My guess is that the time-out value needs to be higher after the NDISDUP command.
Also, we have to test if it's enough to just wait, or if the NDISDUP command needs to be repeated.

Give me some days to get over the jetlag, then I'll work on a test version.

Re: Auto-Start Connection - failing

Posted: 26 Sep 2018, 07:34
by henrysinn
Welcome back!
I thought you might have been away...

PS Would still like to shoot you a donation / Money... How?

:-)