Page 1 of 1

PPP Widget 3 Huawei E303 connecting but no traffic at all

Posted: 10 Jan 2019, 20:37
by lilomaster
Hi:

I am experiencing a problem I have read in other entries in this forum, but that I haven't been able to solve with the solutions proposed.

I have a Huawei E303 modem installed in a Car Head Unit. The car head unit is running Hal9k ROM with Android 7.1.2 and MicroG Libraries insted of the official Google Play libraries.

PPP Widget 3 is installed, it recognizes the modem, connects and creates the VPN, but I cannot generate traffic.

attached are my ppp log file and USB log file, plug a couple of pictures of the ip route and ip link command outputs.

When connected, the HU recognizes the Modem and it provides internet connection through the native internal support, but it is not too stable. It even retrieves the APN directly from the provider, and it shows the typical mobile network connection triangle with the little 3G legend on top of it.

Any help will be appreciated.

Kind regards.

Re: PPP Widget 3 Huawei E303 connecting but no traffic at all

Posted: 10 Jan 2019, 22:59
by Josh
The logs are looking very good.

I think the problem may be here:
lilomaster wrote:When connected, the HU recognizes the Modem and it provides internet connection through the native internal support
Try the following:

- Enter airplane mode; does the unit still use the modem?
- Connect modem (try connecting before and after setting airplane mode)

If that does not help:

- Before connecting the modem, open the terminal app
- Enter "su"
- Enter "setprop ctl.stop ril-daemon"
- Connect modem

Re: PPP Widget 3 Huawei E303 connecting but no traffic at all

Posted: 12 Jan 2019, 16:06
by lilomaster
Thanks for your reply. I tried putting the unit in airplane mode but still no connection. I will try the command you mentioned and I will let you know. I also attach my ip link output. From that information, I think there is another adapter taking over the VPN connection and leaves the tun0 device linked anywhere.

Looking forward to your comments.

Re: PPP Widget 3 Huawei E303 connecting but no traffic at all

Posted: 12 Jan 2019, 21:37
by lilomaster
I've just tested what you suggested but I had no success. Same behavior. It connects through the widget but I have no traffic in any application.

Please, let me know if you need further information.

Kind regards

Re: PPP Widget 3 Huawei E303 connecting but no traffic at all

Posted: 12 Jan 2019, 21:56
by Josh
Are you familiar with the process of Android logging? There is the "adb logcat" command when you access the Android device over a debugging connection; you can also use the free "Catlog" app which can catch the logging on the device and save it.

I need to see the system messages at the moment when PPP Widget is connecting. If you are able to get the log after such a connecting attempt, post it here as an attachment (zipped text is best, full logcats can be large; no image please).

Re: PPP Widget 3 Huawei E303 connecting but no traffic at all

Posted: 12 Jan 2019, 23:41
by lilomaster
Ok. I will try to get the log with logcat and I will post it.

Re: PPP Widget 3 Huawei E303 connecting but no traffic at all

Posted: 13 Jan 2019, 04:09
by lilomaster
In the meantime, I attach my pppWidget 3 Log obtained from SuperSU Pro. Tomorrow I will try to save the catlog reader export.

As I've read in other posts, this log should be enough, should it not?

Please, let me know if you still need the catlog register.

I will be looking forward to your comments.

kind regards.

Re: PPP Widget 3 Huawei E303 connecting but no traffic at all

Posted: 13 Jan 2019, 10:11
by Josh
There is nothing unusual in the IP links or in the SU log.