Automatic Activation, Hotplug and UDEV, Configuration
Post Reply
Posts: 1
Joined: 02 Sep 2018, 09:17

Huawei E8372h

Post by snobN » 04 Sep 2018, 05:48

Hi, i'm trying to use E8372h model of huawei to receive SMS with gammu-smsd on Raspberry Pi 3 B+. However, currently i cannot make it work.
I tried manually switch with Following:

Code: Select all

usb_modeswitch -v 12d1 -p 1f01 -V 12d1 -P 14db -M "55534243123456780000000000000011062000000000000100000000000000"
I got this result :

Code: Select all

12d1:1442 Huawei Technologies Co., Ltd.

Code: Select all

dmesg | grep ttyUSB
It only return 1 GSM Modem ttyUSB0
and gammu-smsd return Error getting SMS status.

I also tried this tutorial but no luck: ... 1439a03790
the gammu cannot regconize the device and failed opening device.

i also tried this code:

Code: Select all

usb_modeswitch -v 12d1 -p 1f01 -V 12d1 -P 14db --huawei-alt-mode
It changed to 12d1:155e Huawei Technologies Co., Ltd
gammu-smsd still can't open device
Please help

Posts: 1
Joined: 12 Apr 2021, 15:21

Re: Huawei E8372h

Post by ethaniel » 12 Apr 2021, 15:22

In case somebody else stumbles upon this - E8372 works in Hilink mode by default.

Only the latest version of usb_modeswitch (check with usb_modeswitch -e, I have 2.5.2) can switch it back to ttyUSB mode. So update it first if you're on an older version.
Then download the new usb-modeswitch-data package from (not available in raspberry repositories yet). Unpack it, and run gen-rules.tcl to install (might require to do apt install tcl first).
Voila. Now you have /dev/ttyUSB*

Next, put this into /etc/udev/rules.d/999-sms-gateway.rules:

Code: Select all

# This rule creates a symlink from /dev/sms to wathever ttyUSB device is assigned to our Huawei USB modem
SUBSYSTEM=="tty", ATTRS{idVendor}=="12d1", ATTRS{idProduct}=="155e", ENV{ID_USB_INTERFACE_NUM}=="00", SYMLINK+="sms", RUN+="/usr/bin/killall -SIGHUP gammu-smsd"
And then use /dev/sms in the gammu settings.

Post Reply